Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

SRE实战 互联网时代守护先锋,助力企业售后服务体系运筹帷幄!一键直达领取阿里云限量特价优惠。

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

解题思路:这是一道考贪心算法的题目,一个木板分成两部分,然后这两部分可以继续分,直到分成自己所需要的木板长度为止,这相当于一个二叉树,并且子叶由父亲分开而来,当然了,子叶肯定会比父亲小,而且每两片子叶的和即是他们的父亲.木板被分的长度越小,叶子节点的深度越深.

代码:

#include <set>
#include <algorithm>
#include <iostream>
using namespace std;
 
int main()
{
    multiset<int> s;
    long long ans = 0;   //用于保存结果 
    int n;
    cin >> n;
    for(int i = 0; i < n; i++) {//把各个短木板放入容器中,利用set容器的自动排序功能 
        int temp;
        cin >> temp;
        s.insert(temp);
    }
    multiset<int>::iterator it;
    it = s.begin();
    while(!s.empty()) { //每次计算出两个最小元素的和赋值给临时变量temp,
    //然后删除这两个最小元素,并把他们的和temp放进容器, 
        int temp = 0;
        temp = temp + *it;
        s.erase(it);
        it = s.begin();
        temp = temp + *it;
        s.erase(it);
        it = s.begin();
        s.insert(temp);
        ans =ans + temp;  //ans加上每一次的临时变量temp 
        if(s.size() == 2) {  
         //当容器中只剩下两个元素的时候,用ans与最后两个元素相加即为最终结果 
            ans = ans + *it;
            s.erase(it);
            it = s.begin();
            ans = ans + *it;
            break;
        }
    }
    cout << ans << endl;
    return 0;
}
扫码关注我们
微信号:SRE实战
拒绝背锅 运筹帷幄